Ouya Discussion

Home Forums Whatcha Playin’? – Gaming Ouya Discussion

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #474
    lovekeiiy
    Participant

    Ouya

    Not necessarily a new discussion. Here are links for the previous blog posts:

    Ouya Shipping in March

    DMiller’s Initial Impressions

    #475
    lovekeiiy
    Participant

    It may be a good idea for my to give my impressions on the Android console.

    First, I was a Kickstarter backer. I think like a day two backer. I did it just to support something different, and an alternative to the big three. There just needs to be low entry point for both game developers and consumers.

    I got my console back on May 7. Setting it up was overall easy. Turn it on, let it update, hold the Ouya button on the controller to pair, set up WiFi/Lan connection, find a game. I messed around with it for an hour. Games were lacking. Controller was acting funny and needed to see if it was the game or controller, but no time to investigate further. Overall, not bad for hundred bucks, like Dave said.

    I finally got around, and remembered to tinker with console. I wanted to install a file explorer, but I need to setup ADB (Andriod Development deBugging, I think). Apparently I didn’t have all the Andriod Development Kit installed. Ouya’s ODK was pretty easy. Just need to set the paths. I did have issues it the console not being seen by ADB, but a nice YouTube video went over step by step, which covered the driver issue I was having. Ouya on Windows Driver Setup

    After it was easy setting up superuser and busybox, per the thread on XDA. I then processed to add ES File Explorer, Voodoo Root Keeper, Titanium Backup, BusyBox Pro, changed to chainfire’s SuperSuperUser Pro. There were of course, a few bumps a long the way.

    Since Ouya has no Google Play access, it’s possible to side load some games and applications. Having an file management application, such as ES File Explorer, makes it a lot easier than having to do an ADB push install.

    Some applicatoins I tried were Netflix, Hulu Plus, and Plex. The current version of Hulu wouldn’t run. I suspect this is because of the lack of Google account and Google Play access. It could also be DRM key as well. I’ve read the hacked version of Hulu that enabled nonsupported devices to access Hulu works. Tried Neftlix. It works, but navigating is pretty bad. You basically have to use the touchpad because the app doesn’t recognize movements with d-pad or analoy sticks. And it bring up the keyboard when browsing, so for searching. Movies play; althyough there may be an issue about no volumne, but apparently just max volumne within Netflix is the fix. Plex for Android, current version, runs fine. I only tested for MKV files, but it was a 20GB rip of Despicable Me and had the Plex app set for maximum video quality. It was transcoding for both video and audio. I was test the Revision3 plugin and no issues.

    I think sided loaded GTA3 and GTAVC. Not a hard setup. But I did need to copy over the obb directories from my android tablet. The Ouya wouldn’t had an error when it tried to download the extra files to run the games. The games ran pretty well. A little video jitter, but I may have the settings too high.

    An interesting result was the OnLive app. It installed with no issue. What surprised me is that the Ouya Controller worked with it. In my previous experience on my smartphones, other controllers did not play well such as Sixaxias Controller or Wiimote.

    Related, I found the OnLive Universal controller worked on the Ouya. I did encounter an issue where the controller was unresponsive, but it was specific to games, and they were all ones downloaded from the Ouya store. I’m not sure it’s Ouya system making some assignment to a specific controller being player 1 or something else.

    I was also able to pair a PS3 controller. It’s weird, when you plug in the USB cable to pair, the blue tooth craps on the console craps out, and you have to shut down the console. But when you turn it back on, it’s paired. I was also about to use a wireless Xbox 360 controller with the usb wireless gaming receiver. The odd part, although it was working, the controller’s light ring kept flashing. Thus, it must be missing part of the drivers that indicate with player the controller is assigned.

    The bad part, it looks like I got one the bad Ouya controllers. Most of the controller worked. Unfortunately, the left analog stick is a mess. A lot of unregistered movements. It made gaming with frutile since the character wouldn’t move, moved slowly, or wouldn’t stop. I’ve written Ouya. Apparently this is a known issue and many people are getting controls replaced when requested.

    As for the controllers, but biggest issue, not all the games work right or designed for them. The select button on all controllers, that it, doesn’t work. It acts like the start button. The Xbox, PS3 or OnLive button all act like the Ouya button. Unfortunately, the Ouya button is designed more a quite button. Thus, when playing OnLive, but button is kind of unresponsive, so the OnLive menu doesn’t come up with pressed. It will quite with a double tap. Since I enabled to leave apps running, when I return, the game is running with OnLive menu running.

    I had a couple times where the Ouya lost it’s internet connect, but was sitll connect to the LAN. I ultimately shut of WiFi and turn it back on in the Ouya settings.

    Overall, there is potential. But the console is still a bit rough. Once more developers start making some games and a few bugs are worked out, it’ll be solid third or fourth console to have around. By design, this is not replacing an Xbox or Playstation. Maybe a Wii, if developers and bugs are worked out, in collecting dust.

    #488
    dmiller68dmiller68
    Keymaster

    Well I haven’t given it as much time as you did. I played with it a few more times but found the exp pretty rough in general. Hopefully they have a few releases to clean it up some in the future. We will see if the Gamestick console is any better. Should have it in another month or two.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.